We are experiencing API stability issue - Ongoing Improvements

Incident Report for CyberSmart

Resolved

The performance has stabilised across the Cybersmart platforms.
Posted Feb 26, 2025 - 17:09 GMT

Update

We are continuing to monitor for any further issues.
Posted Feb 25, 2025 - 11:59 GMT

Monitoring

We are currently experiencing API stability issues in CyberSmart Active Protect due to the recent rollout of our enhanced vulnerability detection system. The new system requires more infrastructure resources, which has lead to performance degradation.
Current Status
API Stability: Increased load on our cloud infrastructure and database is causing slowdowns and occasional instability.
Performance Monitoring: We’ve identified that complex queries on large data sets are contributing to the issue.
Impact: You may experience slow loading or errors in our web product, particularly in the Vulnerable Software module.
Actions Taken
- Scaled up infrastructure to handle increased demand.
- Ongoing monitoring of performance and stability.
- API optimisations underway to improve efficiency and throughput.
We appreciate your patience as we work to stabilise the API this week. Our goal remains to provide high availability, performance, and reliability.
Posted Feb 25, 2025 - 11:11 GMT
This incident affected: CyberSmart Platform (CyberSmart Apps, CyberSmart Dashboard).